Skip to main content

ExtUtils::MakeMaker version is misdetermined.

Posted in


$ pkg_info | grep MakeMaker
p5-ExtUtils-MakeMaker-6.56 Designed to write a Makefile for an extension module

But it says that old MakeMaker 6.42 is not found:

===>   p5-Net-SSLeay-1.36 depends on file: /usr/local/bin/perl5.10.1 - found
===>  Configuring for p5-Net-SSLeay-1.36
Cannot determine perl version info from lib/Net/
Cannot determine license info from lib/Net/
*** Found OpenSSL-0.9.8k installed in /usr
*** Be sure to use the same compiler and options to compile your OpenSSL, perl,
    and Net::SSLeay. Mixing and matching compilers is not supported.
Warning: prerequisite <b>ExtUtils::MakeMaker 6.42 not found</b>. We have unknown version.
Writing Makefile for Net::SSLeay
*** Signal 11
Stop in /usr/ports/security/p5-Net-SSLeay.


This is not a problem of FreeBSD or FreeBSD port of p5-Net-SSLeay. This is the problem of p5-Net-SSLeay. Install it from package.

Thanks for this, needed it!


Post new comment

The content of this field is kept private and will not be shown publicly.
This question is for testing whether you are a human visitor and to prevent automated spam submissions.
                 OooOoo                     Oo    
O OooOoO o O
o o O o
O O oOooOoOo
.oOoO O o o O 'OoOo. o O
o O o O O O o O O o
O o O o O o o O o o O
`OoOo `OoOO `OooOO' O o O O. O
O o
OoO' OoO'
Enter the code depicted in ASCII art style.